Aeon crashes upon saving

Platform: Windows
OS Version: 10
OS Language Setting: english

Aeon 3

Version: 3.0.7
Application Shell: 3.0.7

I opened a file from Aeon 2 and worked on it for a minute or two (the file contains only 10 or so entries). The application crashes instantly upon saving. Reopening and then saving freezes Aeon (AND Firefox) and the app crashed again about 30 seconds later.

Steps to reproduce: Open file. Click save.

  • Are you able to reproduce this bug reliably? Tried it three times. Aways crashed.

  • Can you make this bug happen with a clean timeline file? No

  • Does it only happen with a specific timeline file? It also happened with Wuthering Heights although I hadn’t even made any changes.

Hi Astrid,
Thank you for reporting this. It is the first report we have had of its kind.

There are a few more bits of information that may help us further:

Do you recall if you made any edits to the first file when it crashed, aside from the original upgrade step?

Would you be able/willing to send us a copy of the AT2 file that you are upgrading that is triggering the crash?

If it is at all related to the file, that may be the quickest way for us to identify the cause. We will treat any contents confidentially of course.

When you say it also happens with the Wuthering Heights timeline, do you mean the demo file included in AT3 that you load from the central area of the Welcome screen… or was it an earlier version from another app?

Does the username that you use for your Windows account contain only ASCII characters (primarily A-Z/a-z/0-9), or are there any characters that lie outside this range (accents, umlauts, non-English characters, etc)?


  1. The only edit I made was playing around with the millennia-months slider. I didn’t add any data.

  2. I’ll send you the file via email.

  3. The Wuthering Heights file is the obe I found in this version.

  4. I’m using the account ID you sent me. It doesn’t contain any weird characters.

Thanks for the information.

When you say it crashes when you save the file, do you see a Save Dialog asking you to choose a folder location, or does it crash before that is shown?

If you do see the Save Dialog, where are you attempting to save the file? Is it just to the usual Documents folder, or is it a Dropbox or iCloud folder, or a removable drive, or a network drive, etc?

That information should help me work out when the crash might be occurring.

For #4 in my first set of questions, I didn’t mean your Aeon Timeline account ID. I meant your Windows username that you use when logging into your machine. It will also be a folder name listed under C:/Users/

Sorry for the many questions, it will just give me th best chance of tracking the issue down quickly.