Error on trying to add anything to Narrative

Platform & OS Version

Aeon Timeline
Version: 3.2.22
Shell Version: 3.2.20
Opening Mode: about.editor
Operating System: Windows 10
Device Model: UX303UA

Problem Description + Screenshots

When attempting to add anything to the Narrative, either by right-clicking in the Timeline, or by clicking Add in the Narrative, I get the following error: “Oops, something went wrong and we were unable to perform the last action!”

This file is one I have imported from Aeon Timeline 2 recently, but I have subsequently done a lot of work on it in version 3. I have tried removing Scrivener sync info, but that doesn’t seem to make any difference. When trying to Sync, I do receive a similar error though (“Something went wrong and we were unable to perform the last sync!”), so I presume the problem is there?

BTW, ever hear of error messages that give some information into the cause of the issue?

I don’t get the issue if I use one of the test files or create a new file.

Steps to reproduce

See above.

  • Are you able to reproduce this bug reliably?
  • Can you make this bug happen with a clean timeline file?
  • Does it only happen with a specific timeline file?
    It looks like it.

Any relevant files?

Yes. Email sent.

In case anyone else has this problem, support were able to fix the file very quickly.

They also said: “We have fixed this bug internally and it should be released to beta testing shortly.”


I have this bug on macOS 13.5.2 and Aeon Timeline 3.2.22, I can’t add anything to the Narrative view, I get the “Something went wrong and we were unable to perform the last action” popup too.

What can I do?
Thanks for your help!

If you send your timeline file through to, then if it is the same issue we should be able to fix it and send it back to you.

Hi Charlotte,

We received your email with your timeline attached, unfortunately it seems to have become corrupted through being sent over email, are you able to zip the file and send that through instead?

I also tried to reply to your email with this message, but it bounced.

You can read instructions on how to create a .zip file on Mac here: Zip and unzip files and folders on Mac – Apple Support (AU).