Export to CSV/TSV creates empty files

Platform: Windows 10
OS Build: 22000.978
OS Language Setting: English (UK)

Version:
Application Shell: 3.1.9

Export to CSV/TSV or text produces incorrect dialogs resulting in empty files. This is the first time I’ve tried to do this in some months, so I don’t know when the fault started - The last time worked fine.

Steps to reproduce…
Create a new timeline or use an existing one.
If a new timeline, add an event, name it, and add some text in its summary field.
Choose Export to CSV/TSV. Select comma or tab as delimiter and continue to the save box.
Choose a folder and file name. Select file type. Click Save.
A dialog comes up saying I don’t have permission to save in this location, would I like to save to the Documents folder instead? (Note, this happens everywhere, where I do have permissions, including Desktop and the Documents folder itself - locations where I save things everyday.) Click Yes.
The box changes to the Documents folder (if it was something else previously). Click Save.
The same dialog comes up. Click Yes.
A dialog comes up asking if you want to replace the file. (This happens because a file was in fact saved in a previous step.) Click Yes or No and cancel (to keep the file saved in a previous step) - either way has the same result.
There is now a file saved both in the original location and in the Documents folder. Both are completely empty.
The same thing happens when saving to txt.

Are you able to reproduce this bug reliably? – Yes.
Can you make this bug happen with a clean timeline file? – Yes.
Does it only happen with a specific timeline file? – No.

On the Mac, I can get an empty CSV that’s actually one line - the headers.

The way that happened was if the “selected items only” option was checked.

Unfortunately we were unable to reproduce what you were seeing, so it may be that the error is something specific to your computer.

I have emailed you some questions to help us see if we can work out what the issue is.