How to change "Week starts on" option?


Just bought the 3rd version, thanks for the sale.

I imported my old project from version 2, everything works fine. But for some reason I cannot change the first day of the week (there is Sunday). In Russia where I live it’s Monday:


But when I hit “Edit calendar” button, there I see Monday, which cannot be changed either.

What’s wrong with these settings?

Most settings of a custom calendar cannot be altered once the file has items created, which includes the week it starts on, which is why it would be greyed out for you.
Did the version 2 file that you imported have the week start on a Monday, and then when you imported it, it changed to a Sunday?
We are looking into potentially changing this so it is something that people can alter about their calendars once they have already entered events.
In the meantime, we can change it for you manually, but only for the importation of the version 2 file. So you would have to send your version 2 timeline file to and we can import it to start on Monday.

You will need to change it in the json file in the version 2 file. (its a zip file that you can open in e.g. 7-zip).
It is possible, but you will need to know something about editing json files.

  • Create a copy of the .aeonzip file you want to import to AT3
  • Extract the timeline.json file from the “.aeonzip” file
  • Open it in a plain text editor (notepad, notepad++, vscode, Atom, or similar)
  • This is the section you need to search for:
"name" : "BC-AD Calendar",
               "notes" : "",
               "timeFormat" : "24",
               "weekdayIndexAtZero" : 0,
               "weekdays" : [
                     "index" : 0,
                     "name" : "Monday",
                     "shortName" : "Mon"
                     "index" : 1,
                     "name" : "Tuesday",
                     "shortName" : "Tue"
                     "index" : 2,
                     "name" : "Wednesday",
                     "shortName" : "Wed"
                     "index" : 3,
                     "name" : "Thursday",
                     "shortName" : "Thu"
                     "index" : 4,
                     "name" : "Friday",
                     "shortName" : "Fri"
                     "index" : 5,
                     "name" : "Saturday",
                     "shortName" : "Sat"
                     "index" : 6,
                     "name" : "Sunday",
                     "shortName" : "Sun"

And it shall look like that when you have edited it.

  • Save the edit
  • delete the old timeline file from the zip archive, and add the new one (this is really easy in 7-zip)
  • close the aeonzip file and if your archive software (7-zip) ask if you want to save changes, answer YES.
  • Then you should be able to import to AT3 with correct first day of week for AT2 projects based on the default calendar

This is the standard calendar in AT2, if you made a custom, you will see the name for that calendar.

I made some changes in v3 after import from v2 . I can’t save them? I discovered the first day of the week by accident in the settings view. I don’t even know which one was in v2 and where this option is.

UPDATE. Just checked v2 option in my imported file. I can’t change 1st day of the week in v2 too:

Yes version 2 is the same, you can’t adjust the calendar once events have been added to the timeline.
When you say that you have made some changes in version 3 after importing and can’t save them, do you mean that the program is not saving them? Or that if you want the first day of the week updated, then you won’t be able to keep your changes?
If it is the latter, then yes unfortunately at this point we can only adjust the first day of the week on the version 2 file, so you would lose this data.

@Jaran Thank you! Looks like it’s solved.

One problem is that it was difficult to do on a Mac, so I ran Windows in the Parallels Desktop.

1 Like