I cannot edit the item types

Platform & OS Version

  • Platform: Windows & iPad
  • OS Version: 11 & 15.0
  • OS Language Setting: English

App Version
Version: Windows: 3.0.12 (windows) and 3.0.9 (ipadOS)
Application Shell: 3.0.12 (windows)

Problem Description + Screenshots

Hello, I am trying to edit my item types but it’s not opening. On iOS any attempt to do so just freezes the app while on windows the app displays this error screen. I also tried to do undo, to reopen the file. Restarted my devices, and it’s still not opening.

We received your email with the timeline file, and have replicated the issue, and it has been passed onto our developers to fix at the earliest opportunity.
It is likely that it is something specific with this particular file.

Thank you very much.

Would it be possible for me to received the fixed file? As much as possible, I do not want to have to redo the progress that I made with my file since it did take a while to set up.

Edit: I just saw the email, thank you again! I hope it can be fixed

This has been fixed in the latest update, you should be able edit the item types in your original file now.

I’ve updated and can now edit my item types. Thank you very much!

Though I notice the iOS app hasn’t been updated, hopefully this will follow soon? I am still unable to edit the item types on iOS but I can on my windows laptop

Sorry for the delay in reply, the issue should also be fixed in iOS, are you able to check what version you are using? You can do this by opening Settings, choosing About Aeon Timeline and letting us know the version and shell numbers.

Hello, I was able to update it. Though the first time it asked me to do so, I accidentally pressed no and it was stuck for a bit until I reinstalled it