Installation fails - file libcef.dll cannot be installed

My Acer laptop Acer Aspire A515-51G
runs Windows 10 V.22H2
in the Swedish language (though I write in English)

I’m trying to install the latest version of Aeon Timeline app, downloaded from the Aeon Timeline website. As I can’t install it, I can’t tell you what version it is.

The problem comes when I try to install from the downloaded installation file. Early in the installation process I get an error message regarding the file libcef.dll “Error opening file for writing … click Abort … Retry … Ignore…” (See image below.)

If I ignore the message, the whole of Aeon timeline appears to unpack, but it is inoperable.

I’ve tried copying the file from my Desktop PC (also Windows 10) and pasting it into the Laptop Aeon file, but I am prevented because I “don’t have the authority”. (But I can erase the whole Aeon file successfully as an administrator.)

I’ve tried erasing the whole installation and downloading the installation file again and installing from that, but I get the same result.

I’ve tried copying the original installation file (from 2021) from my PC’s hard disc and installing it on the laptop. The first time I did that, the installation appeared to work, but when I then tried to automatically update to the latest version my virus protection (Bitdefender) intervened and erased the whole file as infected. Since then, when I’ve tried again, the libcef.dll issue repeats.

Are you able to reproduce this bug reliably?

I’ve written e-mails to you about this (on Friday), but not received an acknowledgement.

Trying everything again today I found this forum, so I thought I might repeate myself here in case the e-mails are not getting through.

I would like to be able to use Aeon Timeline on this laptop as I will be travelling for a month in February and away from my desktop PC where Aeon Timeline 3 appears to be working without problems.


Just for others that may have had the same issue, this was solved by installing it on a different location on the computer.

1 Like

Yes. Correct. Problem solved as you say by choosing a different location on the hard disk to install it. Very many thanks for all your help!