Labels for subway graph do not render when exporting to image formats on Windows 11

Platform & OS Version

Platform: Windows
OS Version: 11 Enterprise
OS Language Setting: English + Norwegian Input language

App Version

Version: 3.0.9
Application Shell:

When exporting the subway graph to png, jpg or tiff, the labels to the left for the lines do not print, it do print for the pdf export though…

Sorry you have had problems exporting the subway view. Unfortunately we have been unable to reproduce it, is it possible you could email your timeline file to us at ? This would help us try to replicate what you are seeing so that we can fix it.

It only happens with an imported Aeon 2 timeline, and it has something to do with render time of the image…

Because if I let the " Print Window" stay open for a minute, the Labels slowly occur, one by one, while Aeon use approx. +1500MB of RAM, 4,9% of my Ryzen 9 3900X, and approx. 1% of the GPU.

So Aeon Render the Subway graph it self in a snap, but use approx. 1 min to render the labels.
This is for approx. 20 labels.
If I choose to render every possible item, I only get a little white square in the upper left corner (some kind of render error, but it is unreadable)
Image size: approx. 17000x4000

Same actually happens when I try to print the timeline, it takes extremely long time to render the preview
Image size: approx. 10000x5000)

In fact, on Aeon 2 I can’t export it at all, Aeon 2 Crashes after approx. 2 min of rendering.

Some print screens of the rendering of the preview:

After waiting a few minutes and having the Labels all appear in the preview image, does the export then the labels correctly to the image? So the problem only occurs if you try to export straight away?
How many labels do you have in total (that causes the little white square in the upper left corner?)

I think so, I need to retest this later today… forgot if I actually tried exporting it or not when it was finished…

number of labels: will count them.

But this is also a problem for the timeline, and there I have maybe a few hundred items for this project, some are nested, some have constraints, some are duplicates.

It seems Aeon can render the graphic, it doesn’t seem to be a problem for the example timelines…
I have another small to medium historical project in ver. 2 with about the same amount of items, I will see if the problem is the same with that, I don’t remember if I was able to actually export that project at the end…
It will see if I can get it done later this evening (Norwegian time).

THis test is running on the same hardware and with the same resources utilized in the task manager as mentioned earlier.

I am not sure how I can find out how many Items I have in total for the Export problem with the Timeline, Starting to manually count all the items will take “ages”+1.

For this todays export test with the subway view, I have 30 labels and the size of the plot render at 26120x2864 points.

I get multiple “crashpad_handler.exe” processes for Aeon (some was most likely the attempt to export the timeline, some the attempt to export the different subway view I tried.

It took 11 minutes to generate the preview before I could save it as an png.
Yes, the Labels did print…
The png file is a little over 6MB and not the structure is “not that advanced”
This is a printscreen only, to reduce the size…

PS. This is a subset of the project, to try the same with all items would just take to long.
the "full timeline will render to 49215x8749 points at a “medium” sized timeline…

This “rendering” doesn’t generate a “crashpad_handler.exe” instance in task manager, it just gives me the render points of the image and then goes straight to the “White Square”…

I have also tried to reduce the timeline scale down (centuries<days), and first when I come down to approx. 9400x8700 point, the timeline started to render a preview
12000x8700 points does not render (White Square)

So In practice I have no way to export the project to any viable format.

My GPU is not of the newest, but it is OpenGL enabled, and usually keep up with most graphic software I use, both with and without OpenGL, DirectX etc.

And I actually have the same problem if I try to export the timeline of the “Murder on the Orient Express” in a size of approx. 10000x5800 points. Over that size, it will not render.
GPU usage approx. 1-4%
CPU usage approx. 4-5%
Memory usage approx. 2900MB out of 64GB total
And it seems that Aeon utilize only 1 core out of 12.

As it state when you create plots of a timeline over 50kx50k, it do support 50k square plots…
But even that is small for a large timeline going over multiple decades when you need days as accuracy for the project.
I don’t know what type of plotting you do, but maybe you should plot using vector graphics if you today render directly to bitmaps graphic…

I will not be able to export my projects to any visible graphic format if the limit of 50kx 50k will be standing… so please support at least one vector format with unlimited project size.

The export to pdf or images do not work at all when trying to export a timeline over 10k-12k (largest side size) image size.

In practice this block me from exporting both my timelines and my subway graph in a readable size.

Reducing the size of a project that goes over 30 years and that need day precision under 10k long side image by zooming out the timeline, make the rendered image not understandable (You can see any details other that “years”.)

And to wait 10-20 minutes or even more for a subway graph to render that is not very user friendly, since you cant work on your timeline while this export is going on.

I also the limited to the render to 50kx50k (or maybe 65kx65k) Images is problematic, when most larger project will render to at least 100k to 250k on largest side… Historical projects maybe even more when there is a few thousand Items and maybe a few hundred or more Events…

How will we be able to visually display and publish our timelines?

I think one solution would be that you exported to vector graphic like SVG, ODG or other similar formats… then we can convert to bitmap if needed in a software that is specific for that purpose.

Thanks for the report. We will look into the timing to see why it is taking so long. Unfortunately it is dependent on the external libraries we are using, but we will look to see what we can do. Internally it is generating a PDF, which is effectively a vector graphic, and if the delay is occurring during the preview phase, then the PDF generation would be the slow part (not the image creation).

This article describes ways to share timelines currently: Alternatives to web export - Aeon Timeline 3 Knowledge Base

Ah, yes it is… Since I only could export small pdf, I have never really looked into that, I though you just wrapped a bitmap in a pdf container…

So, I opened the pdf made after some 20 min of waiting and looked at the construction of the lines in the subway graph…

And I think I know at least one of the reasons for the long render time…

Each line is made up of hundreds of small pieces of of straight lines…
Only the lines without “cross points” was somewhat one single object.
It looks like all Lines for items that have some interaction with another item is built up of chunks of 75px line objects after the first waypoint.

for my subway graph that make the graph being build by 3425 separate objects… and that was only a subset of my project.
My timeline for the same project I can not check the same way, because I can’t get a usable pdf out.

When all those tiny line parts shall be stitched together, it has to take an enormous amount of time as long at the resources used is limited, i.e. only use 4-20% of one single thread on a 24 thread CPU, but spinn the GPU up in the roof for 3 second, for then to only utilize 4-10% of it for the rest of the time…

It is a great way to build a graph, but maybe it is possible for you to change the hardware resource utilization of the rendering?

Maybe it would be possible to set how many threads and how much memory (incl. shared) the render engine use?
And have a setting for Aeon that the user can change, but have a default of i.e. 10-20% of available resources, while people that runs on new high end platforms can select i.e. 32GB out of 64GB of RAM, and set it to use 12 or 18 threads out of 24 (in my case).
But for others that may have 4-8 cores single threads CPU’s, at least they can set it to use half of them?

It would also be great if you could find a way of supporting large bitmaps

Yes, I know about those, but it can’t be compared to having an image in a document, or attached as a file to an object as a media file in another software, i.e. either embed an image to a markdown file, or link to it, or attach a image in i.e. Gramps, or another database for the research object you are working on… sometimes a “local” graph, i.e. the object and only the close neighbors is not enough to illustrate a context of a conclusion.

And even though pdf is a “vector document”, it is usually handled as a pdf document file, not an image file… so the content of the pdf is not rendered as an image in most previewers…

I hope you can see and understand the differences here…

Anyone that works with larger projects, i.e. Project Management, Larger Legal Cases with lots of Events and sources, etc. or Historical Projects with lots of items, will come to the same problem when the want to export a project with i.e. day precision… and genealogy projects, going back hundreds of years to… they all will have some problems with this when they want higher precisions on their exports of the timeline, or want many items in the subway graph to show i.e. interactions between families or people vs. locations… i.e. who actually was at that place at a given time…

I really hope you find a solution or at least give another option to just render a vector format straight to a vector format image file without any overlays and extra wrappers…

I have not studied the pdf format to any length, but it might be that that is why the limitations for the size is what it is… a vector image format will not have arbitrary size limits PDF has some 200x200inch limit in dimension i think, even though a "modern version support way larger dimensions than that… maybe if you change the pdf version to the latest or something?
i.e. 1.7.

by checking the document properties of the subway graph that I managed to export, the dimension when changing from px to inch shows a largest size dimension of 196,23inch. it is a little over 14000pt.

PS. it can be that I used have used the “px” somewhere, but I actually ment “pt”, just so you know… it’s a typing error if so have happened…

Maybe this two posts with their questions and answers can be of some help.

I did noticed that the pdf of the subway graph was pdf ver. 1.3…
while the one timeline I got out of Aeon 2 actually was version 1.4…
(why different versions? and why an older version in a newer version of your software?)

So maybe you can get larger documents exported just by changing the pdf version to 1.6 or even the newest 1.7, and set the UserUnit property.

Thanks for this, we are aware of some of these issues that could be causing the slow rendering and will be looking into refactoring how some of this is done in order to get the exporting happening faster. In terms of the pdf version, this is just what is supported by the library that we are using, which is a different one than for version 2.

Then you need to ask the developer of that library to support newer pdf versions.
Both regarding the size, but also regarding safety issues… or change to another library that support newer versions of PDF and larger dimensions.
Or just simple support export to SVG without constraint or limitations. and let the user convert to bitmap if needed… most text and word editors support SVG and SVG is also supported by html5…
It’s also easy to convert or even alter SVG with an open source and free software like Inkscape or Krita… And the the best part is that the format is Open Source.

There is a lot of nice feature in Aeon 3, you really shall have a lot of credit for that, but there needs to be good ways to actually use the result. so please, add support for export to SVG without any constraints…

This case is actually about a lot more than just the labels not rendering…

It is about not be able to export larger timelines to any of the “image” formats.

So, is it any updates on this?

When can we expect to be able to export our projects to any usable sizes and formats?

There is an update coming that should make the render times for exporting to PDFs faster, it will be put out to beta next week and we expect it would be released a week or so after that.

Thank you…

But have you also changed the PDF version used and fixed the arbitrary dimension limit the 1.3 version makes?

As long as the PDF version used is older than 1.6 the dimension limitation will still block the export from render anything useful for bigger timelines, when you want to display a high detailed timeline.

e.g. if you have a large timeline spanning multiple decades and want to show days in it, the dimensions of that timeline will be way more than the limit of 50k x 50k points.

This is an arbitrary limitation made by the PDF version, and would not have been if you either used a newer PDF version (newer than 1.6) or a vector image format like SVG or similar.

No the PDF version hasn’t changed, as this is determined by the external library we are using it is unlikely to change in the short term. Our investigation into the issue found that the core issue was to do with rendering the preview, and having fixed that, we haven’t encountered any situations where the PDF version is a particularly limiting factor.

The dimensions limitations of the PDF version is absolutely a limiting factor.

Try to create a timeline that span 50-100 years, add 200 events spread out on those years, set the timeline zoom so that you can see days, and try to export the timeline.

Guaranteed the dimension limit of approx. 50k x 50k points will block you from exporting the timeline or the other views.

I’m working with historical data and it is important that if I am going to showcase my project, that I can display it in a usable view, i.e. actually show the plot of events over time, not just a microscopic vertical line of “dots” on a dark background.

So I have practically bought a totally useless software! since there is no ways other than a screendump to visually display a timeline.

And no, the “send a file and ask the other person to install the free AT3” workaround, is not a solution at all.

This has actually gone from bad to worse!