Lots of trouble with your update purchase

Windows 11 latest, Chrome latest, both releases not dev versions

As the beta has ended, right about where my year ran out, I couldn’t use the 3.2.17 release without an upgrade.

  • you don’t cater for this on your website
  • so I had to use the pop-up arrangement from the app , where there were many problems
  • I tried to pay with Amazon. I got as far as the screen to log in to my Amazon account, which is not adequately clear that it is indeed Amazon and its security providing that screen. Quite a few minutes out trying to nail down about that, not 100%, and whom FastSpring may be.
  • I went ahead anyway, and got a weird summary refusal from Amazon – Unknown error incomprehensible response from profile endpoint. I managed to close it, app wouldn’t restart payment unless I restarted app. More fool me, I tried it twice. Screenshot attached.
  • So, I went back to PayPal. This was much clearer who it was, though not entirely, with FastSpring notations…but it did operate as am used to, including 2FA, and completed the purchase. At which point the popup froze, could not be closed, app also was frozen, and I had to close app window to get rid of this combination. Screenshot also attached, if I’m more fortunate here.

Sorry to have to report so much trouble, but I’d think you want better than this, not to push customers away.

Might I suggest, an ordinary upgrade page on your website?


Amazon failed:

Paypal locked:

Hi Clive,

I’m sorry that you have had so much trouble trying to purchase updates from us.

I have contacted FastSpring to make them aware of this issue so they can look into it and fix the problem.

The payment did go through successfully, so let us know if you find that you are still unable to get the latest upgrade.

Thanks, Jess – hoping this turns out an easy fix, and will help others.

Take care,

Same problem with Paypal for me… now it has been spinning for 10 minutes.

In addition, before I wanted to upgrade to 3.2.x, it stated that I could update for free to 3.1.9, but I already have 3.1.9, so why would I run an update of the same version I already have installed?

If you come across this issue with Paypal, if you email us at support@timeline.app we can confirm if your purchase has gone through for you.

In regards to the update message, whereabouts in the app were you seeing this?

I got a confirmation by PayPal an hour or so later and after I was forced to kill Aeon with the Task Manager and later restarting Aeon after that I also got confirmation in Aeon after I had to reenter my email and “code”… for some reason that information was removed from the software…

A lot of problems with this update…