Scrivener Sync Not working

Platform: Mac
OS Version: 13.3.1 (a) (22E772610a)
OS Language Setting: English

Aeon Version: 3.1.8
Aeon Application Shell: 3.1.6

Scrivener version: 3.3.1

I have been developing my novel in Scrivener and Aeon. Recently I began to notice that when I would sync the two projects together, the order of the scenes would be incorrect in both applications after running the sync. I thought perhaps it was because I was making changes in both applications before running the sync. So recently I did a long stretch of work in Scrivener ONLY, before syncing to Aeon. I compiled an outline of my scenes and printed it, so I could check the results of the sync. After the sync, about 12 of the scenes were in the wrong order in both Scrivener and Aeon-- Aeon had improperly interpreted the order of the scenes in Scrivener, and applied the incorrect order to both documents. I put the scenes back in the correct order in Aeon, and then synced again, and after that both Scrivener and Aeon are properly synced.

I am not sure how to reproduce the errors, but I can say that all of the documents remain in their proper narrative folder, even when they are out of order after the sync.

  • Are you able to reproduce this bug reliably?
    Yes. I have been observing this for some time, and trying different fixes, including resetting the sync. And, no, in the sense that I have no idea what triggers the improper order.

  • Can you make this bug happen with a clean timeline file?
    Haven’t tried. Honestly it’s too much work! I would have to create a timeline file with hundreds of events and items.

  • Does it only happen with a specific timeline file?
    I have never had this problem with Aeon before. But I have been working on this file and project for two years (no others), and I was not having this problem until recently-- only started noticing it in the past month, when I began to do extensive restructuring of my project. The last time I did extensive restructuring, about 10 months ago, I did not have any problems with sync.

I am forwarding my Aeon file and my scrivener file by email, as requested.

This is probably not going to be helpful, but here goes. Syncing to Scrivener is ordered in the Outline tab. Are you by any chance thinking that it’s ordered by the Spreadsheet tab? (I doubt this is helpful since you have plenty of experience with AT3 and no doubt are well aware of how it is supposed to work.)

I am aware of that, but thanks for trying! This is a direct outline to binder sync problem. Perhaps one of my files got corrupted somehow. I have sent them both along to Aeon in hopes they will be able to comment. (As I was searching today, I ran across your posts about ordering events without times-- an issue that I bumped up against awhile ago, and was happy to resolve. Nice to meet you! Seems we are sharing a workflow!)

1 Like

Nice to meet you, too. :slight_smile:

It’s nice to know someone is actually using AT3 and Scrivener in sync to write fiction. I was beginning to think I was the only one!


I have a similar issue.
I tried to create a new AT file and to set up the sync with my Scrivener project.
AT is able to retrieve all the docs listed in the folder I chose, and if I change the title, it can see there is something to sync.
But the sync button on the top disappears, even if there are changes to sync.
I have to reboot the app for it to reappear, and if I click on it, save, then close and open my Scrivener project, the changes havent been synced.

And last but not least, I can not add any Scrivener file to any view, Timeline or Narrative…

So the link with Scrivener doesn’t work at all…

Sorry you have had trouble syncing.

If you come across it again, are you able to post a screenshot of when you have changes to sync, but the Sync Now button is not appearing?

Is it possible for you to send through your timeline file and Scrivener project to ? If we can replicate what you are seeing we should be able to work out why the syncing isn’t working.

Just to clarify, so from what I can gather, you were able to sync your Scrivener documents into Aeon Timeline, but any changes you made in Aeon Timeline and then synced, did not get loaded back into Scrivener? Are they still appearing as changes in the sync binder in Aeon Timeline, or does it think things are in sync?