Selection missing when creating relationship in Inspector

Platform & OS Version

Platform: Mac
OS Version: 12.3.1
OS Language Setting: German

App Version

Version: 3.1.5.
Application Shell: 3.1.5

Problem Description + Screenshots

When I go to the Inspector to add a relationship I can hover over the item types and usually a submenu appears with the possible relations. Frequently, on some of the types, the submenu simply won’t appear. This is very inconsistent. I need to click outside again and trigger the menu again by hitting “add relationship” and if I repeat this maybe four or five time, finally the submenu will appear. But the others do appear! I can’t tell right now if this behaviour is alway affecting the same items. In the screenshot, the item “organisation” should have a submenu, as in the first shot, but it just doesn’t pop up (second shot). As I’m writing this, it happens with “organisation” all the time, but I can’t say for sure if it wasn’t another item in the list on other days. Also, I tried another project with totally different item types and it happens there as well. It does not relate to the number of possible relations, it also happens with items that offer only a single relationship type.
It happens on my older iMac as well as on my brandnew M1 MBA.

Steps to reproduce

  • Are you able to reproduce this bug reliably?
    It seems to happen randomly but very often.

  • Can you make this bug happen with a clean timeline file?
    No, but a clean timeline file doesn’t offer a lot of item to choose from anyway.

  • Does it only happen with a specific timeline file?
    No, at least with two totally unrelated files.

PS: I just tried it with the “murder i. t. O.E.” template and it is the same! E.g. when I open Mr. Ratchett, click “add relationship” I see the submenus for Backstory and Clue, but for Character group it doesn’t open the submenu. But after hovering over it for about ten times (even without the clicking outside/add relationship again step) it finally appears. Hovering on something else and going back to Character Group, it gone again.

Sorry you are having issues with these menus, we have been able to reproduce this on our end, so will pass onto our developers to fix.

1 Like