Version 3.0.12 just released, further updates next week

Version 3.0.12

Aeon Timeline 3.0.12 has been released for Mac and Windows. An iOS release for 3.0.12 will be coming shortly, but has been temporarily held up by a slow Apple review process.

Most significantly on Desktop, this update fixes a number of issues related to Scrivener syncing.

You can read full details of the release here:

Performance Updates Next Week

We have also been investigating some of the performance issues associated with large files on this device, and will have an update ready early next week which will address the most significant bottlenecks.



Unfortunately, my current version won’t update to 3.0.12 using the official procedure. I can see the outline of a new window (probably the update process) for a fractional second. Then nothing.
When I restart TL, it’s still at v3.0.11.

I’ve tried 5+ times now and disabled my anti-virus.

A manual install worked, as described by Drakemoor

Updating from the app doesn’t work for me. I’m currently on 3.0.11.

It shows that there is an update available and when I click on the label it restarts the app. When I reopened it the version it shows:

I had the same problem with the update process from 3.0.9 to 3.0.11. I managed the install the .11 update manually. I have no idea what causes the problem. I even tried to turn off my antivirus and run the installation process as admin to no avail.

Downloading and manually installing the .12 version did the job.

Thanks for letting me know.

Are you both on Windows?

It is clear that some Windows users continue to experience issues with the automatic updates, although I have been unable to reproduce this myself so far.

I will look into providing a separate fallback mechanism if we detect that the auto-update failed.


I assume it’s likely to be something very specific. There are programs where the automatic updates do stutter for me and I sometimes have to resort to manual downloading - but Timeline has updated perfectly so far.

Yes, Windows 10.

I was able to update the program on the second attempt.
Windows 10

1 Like

Yes, I’m on Windows 10.

So the latest update totally hosed my install… hitting update to 3.0.12 restarted aeon, but now just get a white window when aeon opens… i tried to redownload a copy and install that way… same issue… i literally get nothing now, not even read only mode…

On MacOS… but this update broken it big time… :frowning: I also totally zapped Aeon using the appzapper app to remove everything… and then reinstalled fresh form a .dmg and nope… same…

and just to confuse further… I downloaded the mac appstore version 3.0.12 and it exhibits the same behaviour…

Sorry you have had this problem when updating the to the latest version. This is a currently known bug that we will be providing a fix for, and are hoping to release today.

1 Like

For anyone who has had the above issue (either white screen or blue screen), an update with the fix has been released, however you will need to download and reinstall the latest version from our website here: Download | Aeon Timeline instead of updating through the application.

1 Like

yup… confirmed 3.0.13 fixes this (the mac appstore version just updated to 3.0.13 as thats the last version i’d installed to try and fix)… and in read only mode… its now working fine again… nice fast fix… well done!!!

After years of not using AEON - in part I was waiting for SCRIVENER to update to version 3 for Windows - I got an email about the update and sale. I decided to buy version 3, mainly because my old version 1 rego code wasn’t applicable - and I’m glad I did.

I write comics with multiple characters and storylines, and the new version looks so much more helpful than the original. There’s a LOT for me to learn, but I look forward to doing just that. This is just what I need to easily keep track of things.

Oh, I also noticed that AEON is now owned by SMITH MICRO. I have nothing but GOOD experiences with Smith Micro after buying Manga Studio way back when.

I’m glad you are looking forward to using version 3, let us know if you need any assistance with it.

However Aeon Timeline is not owned by Smith Micro (nor has it ever been), where did you get this information from?