[3.0.22] Cannot link items to scrivener if previously ignored

Platform & OS Version

Aeon Timeline
Version: 3.0.22
Shell Version: 3.0.22
Opening Mode: Editor
Operating System: Windows 10
Device Model: System Product Name

Problem Description + Screenshots

Provide a detailed description of the bug that you encountered. Please include any screenshots that are relevant.

Steps to reproduce

I have a timeline where I previously synced items as “Ignore” (because previous of version 3.022 there wasn’t the search feature in the Sync inspector panel). Now, if I try to change the binding of such ignored items to some existing item in the timeline, nothing happens.


I click on change, choose an item, but nothing happens. It stills shows “Ignore”. It seems to work only if I choose to link it to a new item.

Even if it seems to work this way (but it’s not acceptable), I don’t understand why it says “Deleted from Narrative”. If I chose “Create new” from the dropdown, why is has to be “Deleted from narrative”?


Further testing shown an even weirder behaviour.

Clicking on change and then choosing an item seems to do nothing at first (it still shows “Ignore”), but if I sync the timeline with scrivener anyways, it goes crazy as follows:

I click on “Jen tenta di evadere”

Nothing happens.

Then I force a sync with scrivener (Aeon thinks no changes happened. That’s what I mean by “forcing” a sync)

It goes crazy, binding the item to a random one. (It should have been “Jen tenta di evadere”, remember?)

At this point in time, binding to scrivener seems really dangerous, because it can lock your syncing permanently. (btw… any plans on “unlinking” previously linked items? Allowing it would prevent really nasty bugs in the future, like this one.)


Sorry you are having these problems with syncing.
We have been able to reproduce these issues, so will pass onto our developers to fix.
I will add your suggestion for the ability to unlink events to our feature request list.

1 Like

This bug is REALLY annoying. Is there any ETA for this one?

1 Like

This bug has been fixed internally and will out in the next beta shortly.
Once it passes beta testing it will be then be released in the next update.

What version of Aeon are you using? 'Cause I can’t find the option to change or ignore items anywhere. I’m on the latest 3.0.22

As the thread title says, I’m on 3.0.22.

You have to keep the inspector open to be able to ignore items from sync.

Yes, this is exactly my setup. Unfortunately, I don’t see the what you are seeing. There is no way for me to ignore or ‘change’ the syncing behavior. Super strange.

this is what I’m seeing in the inspector:

This is a known bug. (or a feature request depending on the point of view).

Once an item is linked, your are doomed. Your only option, at the moment, is to duplicate the scrivener file, link that duplicate to the item of your choice in aeon. Then delete the “source” scrivener item.

Hope this much needed feature of “unlinking/changing link” will be implemented ASAP.


1 Like