[3.1.5] Linking previously ignored items to Scrivener still not working

Platform & OS Version

Aeon Timeline
Version: 3.1.5
Shell Version: 3.1.5
Opening Mode: Editor
Operating System: Windows 11
Device Model: 20EV0035IX

Problem Description + Screenshots

Unfortunately, it seems that the infamous bug is still here, as already pointed out in [3.0.22] Cannot link items to scrivener if previously ignored - Bug Reports - Aeon Timeline, although it behaves a little bit different.

With version 3.1.5 looks like I’m able to link previous ignored items (I’m still not sure if it’s not messing them…), but some of them look weird before attempting any linking. In fact, it’s not possible.

As you can see, Aeon tells me that the item is ignored (that is correct) but the inspector says is linked (absolutely false. See following screen)

The event that the inspector is pointing to is not a linked one. So, this is not a fault on my side.

Sorry you are having problems with the syncing still. Is it possible for you to send through your timeline file and Scrivener project to support@timeline.app ? This will help us work out what the issue is.

Email sent. Apologies for the large attachments, but the project is quite big.


Since the bug have been acknowledged, is there a dirty and raw hack I can apply to fix my project and make it work?

I’m in need of having a fully working narrative and I can’t have one at the moment because I can’t bind certain items.

Is there something I can manually edit in the json content of the project file? I’ve tried, but there is too much stuff to reverse engineer by myself.



Hi Matt,

Unfortunately there wouldn’t be anything you could do manually to fix this issue.
However we might be able to alter your file on our end and send it back to you
Our developers are still looking into the issue (they haven’t been able to find the circumstances that cause it to happen from a brand new file), but may be able to update your file to work before the fix would be released in a general update.
They will look into this, and I will get back to you with what they find.

Hi Matt,

The bug has been fixed internally and should be released next week. I have sent you an email with your fixed file in the meantime.

1 Like

That’s amazing!

Thanks! :slightly_smiling_face: